تکنولوژی MPLS چیست ؟ – بخش سوم

در ادامه مباحث MPLS در خدمت دوستان هستیم و در این بخش می خواهیم Peer to Peer VPN را مورد بحث قرار دهیم.

Peer-to-Peer VPN Model :


روترهای Service Provider در مدل Peer to Peer VPN داده های مشتری را در شبکه خود حمل می کنند و همچنین در مسیریابی ترافیک مشتری شرکت می کند. در تعریف دیگر ، روترهای Service Provider برای مسیریابی ترافیک با روترهای مشتری همکاری می کنند که نتیجه آن ایجاد یک رابطه همسایگی بین روترهای مشتری و Service Provider است. در شکل زیر نمونه این شبکه نمایش داده شده است :

Image

قبل از اینکه MPLS به وجود آید برای ایجاد شبکه Peer to Peer VPN ، مسیریابی IP با Peer کردن روترهای مشتری و Service Provider انجام می گرفت. همچنین این شبکه نیاز داشت که حریم خصوصی و ایزوله کردن را برای مشتریان انجام دهد که این کار توسط فیلتر کردن بسته (ACL) برای کنترل داده های مشتریان انجام می شد. راه دیگر برای اینکار استفاده از فیلتر کردن Routeها بود یا هر دو روش در کنار هم مورد استفاده قرار می گرفت.
قبل از ارائه MPLS استفاده از مدل Overlay VPN توسط Service Providerها معمول تر از مدل Peer to Peer VPN بود. مدل Peer to Peer VPN نیاز به تدارکات زیادی داشت چون اضافه کردن یک سایت مشتری نیاز به تنظیمات فراوانی در بسیاری از سایت ها به وجود می آورد. یکی از کاربرد های MPLS VPN این است که باعث می شود مدل Peer to Peer VPN به سادگی پیاده سازی گردد.
با استفاده از MPLS امکان حذف و اضافه کردن سایت های مشتری به سادگی قابل تنظیم است و نتیجه آن کاهش زمان و حجم تنظمیات است. در MPLS VPN یک روتر مشتری که به آن روتر ( (CE گفته می شود با حداقل یک روتر Service Provider که به آن (Provider Edge (PE گفته می شود در لایه سوم با هم Peer می شوند.
حریم خصوصی در MPLS VPN با استفاده از (Virtual routing/forwarding (VRF و ارسال بسته ها در Backbone شبکه Service Provider با استفاده از label بدست می آید. با استفاده VRF از جدا نگه داشتن اطلاعات مسیریابی مشتریان مختلف از یکدیگر اطمینان حاصل پیدا می کنیم و در Backbone شبکه مطمئن می شویم که ارسال بسته ها براساس اطلاعات label صورت می گیرد نه اطلاعات آدرس IP.
شکل زیر مفهوم VRF و ارسال براساس Label در Backbone شبکه در MPLS VPN نمایش داده شده است :

Image

در شکل زیر شبکه Peer to Peer VPN در MPLS VPN نمایش داده شده است :

Image

در MPLS VPN برای اضافه کردن یک سایت مشتری ، فقط روتر PE با CE باید Peer شوند و دیگر نیاز به ایجاد Virtual Circuit در مدل Overlay VPN یا فیلتر کردن بسته ها یا Routeها در مدل Peer to Peer VPN نیست این یک مزیت بزرگ برای Service Provider ها محسوب می شود.
اکثر مشتریان Service Provider ها نیاز به یک شبکه Hub and Spoke دارند و بعضی از مشتریان نیاز به یک شبکه full mesh دارند و بعضی دیگر یک شبکه بین این دو حالت نیاز دارند. مزیت MPLS VPN برای مشتری زمانی ملموس می شود که مشتری دارای یک شبکه Full Mesh است.
دو تصویر زیر را با یکدیگر مقایسه کنید. در تصویر اول مشتری یک شبکه full mesh روی بستر frame relay دارد و تصویر دوم مشتری یک شبکه full mesh روی بستر MPLS VPN دارد.

Image

 

Image

در تصویر اول هر روتر لبه مشتری باید به همه روترهای لبه دیگر خود Peer شود که تعداد آن n-1 می شود اما در تصویر دوم هر روتر لبه مشتری تنها با یک روتر لبه Service Provider باید Peer شود.
مزیت دیگر برای Service Provider این است که تنها باید یک link بین روتر PE و CE ایجاد کند در صورتی که Service Provider در مدل Overlay باید بین همه سایت های مشتری link یا virtual circuit ایجاد کند. در روش MPLS VPN پیش بینی ترافیک و فراهم کردن پهنای باند مورد نیاز برای ترافیک برای یک سایت خیلی راحت تر از پیش بینی ترافیک برای کل سایت ها انجام می شود.
تنها معایب روش Peer to Peer VPN نسبت به روش Overlay VPN به شرح زیر است :

  • مشتری باید در مسیریابی با Service Provider شریک شود.
  • دستگاه های لبه Service Provider بار بیشتری را متحمل می شوند.

اولین عیب روش Peer to Peer VPN این است که باعث می شود که مشتری برای مسیریابی با Service Provider باید Peer شود و این باعث می شود که مشتری کنترل کاملی روی شبکه خودش نداشته باشد در اینجا منظور مسیریابی در لایه سوم است چون بخشی از این کار توسط Service Provider انجام می گیرد و مشتری روی آن کنترلی ندارد.
دومین عیب این روش به Service Provider برمی گردد افزایش بار برای شبکه Service Provider باعث اضافه شدن وظایف روترهای PE می شود. Service Provider در قابل گسترش و تبادل اطلاعات مسیریابی مشتریان مسئول است و این روترهای PE هستند که وظیفه حمل بموقع دیتا مشتریان را دارند.

برداشت اشتباه :


یکی از دلایل اولیه برای استفاده از label switching نیاز به سرعت بیشتر بوده است چون سرعت IP switching نسبت به label switching پایین تر است. در IP switching روتر بسته های IP را با استفاده از آدرس مقصد بسته که در header بسته قرار دارد و پیدا کردن بهترین مسیر از جدول مسیریابی خود برای آن مقصد ارسال می کند. اجرای این مراحل به برند و عملکرد روتر بستگی دارد. به هر حال چون آدرس IP می تواند به صورت unicast یا multicast باشد و از چهار octets تشکیل شده است بررسی آن می تواند پیچیده باشد. منظور از پیچیده ، این است که تصمیم گیری برای ارسال بسته های IP می تواند زمانبر باشد.
اگرچه برخی از مردم تصور می کنند که بررسی یک برچسب ساده نسبت به آدرس بررسی IP می تواند خیلی سریعتر باشد اما در واقع اشتباه است و روتر برای ارسال بسته از ASICs استفاده می کند که باعث می شود سرعت ارسال همانند label سریع باشد. در نتیجه سرعت بالاتر MPLS یک برداشت اشتباه می باشد.
نکته : قبل از MPLS ، معروفترین پروتکل WAN را می توان ATM و Frame Relay نام برد.
نکته : اندازه فیلدی که در فریم ، label را نگه داری می کند 32 بیت است.

تکنولوژی MPLS چیست ؟ – بخش دوم

در ادامه بخش قبلی سایر مفاهیم تکنولوژی MPLS را مورد بحث قرار می دهیم با ما همراه باشید.

بهینه شدن جریان ترافیک (Optimal Traffic Flow) :


با توجه به اینکه سوئیچ های Frame Relay یا ATM یک دستگاه لایه دو هستند روترها برای اتصال از یک مدار مجازی استفاده می کنند. هر روتر برای ارسال ترافیک به صورت مستقیم به هر روتر Edge دیگر باید یک مدار مجازی بین آنها ایجاد گردد. ایجاد این مدارهای مجازی کار خسته کننده ای است. حال اگر در این شبکه نیاز باشد همه سایت ها به یکدیگر ارتباط داشته باشند باید توپولوژی Full Mesh را به وسیله مدار مجازی بین سایت ها ایجاد کنیم که یک کار سنگین و هزینه بر می باشد. اگر سایت ها مطابق شکل زیر (non-Fully Meshed) به یکدیگر متصل باشند ترافیک از CE1 به CE3 از CE2 عبور می کند.

Image

نتیجه این می شود که ترافیک یک مسیر انحرافی را دوبار طی می کند که باعث هدر رفتن پهنای باند و درگیر شدن روتر CE2 می شود.
اما زمانی که MPLS در این شبکه پیاده سازی شود ترافیک به صورت مستقیم بین سایت ها جریان پیدا می کند و باعث بهینه شدن جریان ترافیک بین سایت های مشتریان می گردد.

مهندسی ترافیک (Traffic Engineering) :


بحث مهندسی ترافیک به منظور استفاده بهینه از زیرساخت شبکه است به این معنا که مهندسی ترافیک بتواند امکان هدایت ترافیک در شبکه را از مسیرهای مختلف غیر از بهترین مسیر را فراهم سازد. بهترین مسیر براساس کمترین هزینه توسط IP Routing انتخاب می شود. این هزینه توسط پروتکل های داینامیک مسیریابی برای پیدا کردن کوتاه ترین و بهترین مسیر محاسبه می گردد. با استفاده از مهندسی ترافیک MPLS که در شبکه پیاده سازی شده باشد شما می توانید ترافیک با مقصد خاص یا QoS خاص را از نقطه A به نقطه B از مسیری غیر از بهترین مسیر عبور دهید. در نتیجه ترافیک روی همه لینک های موجود تقسیم می شود و باعث می شود از همه توانایی شبکه به بهترین شکل استفاده شود در شکل زیر یک نمونه نمایش داده شده است.

Image

همانطور که در تصویر می بینید شما می توانید ترافیک را از نقطه A به B از مسیر پایین انتقال دهید در این مثال مسیر بالا بهترین مسیر بین نقطه A و B است چون مسیر بالا نسبت به مسیر پایین کوتاه تر است. در نتیجه برای ارسال ترافیک ما از مسیری استفاده کرده ایم که کمتر مورد استفاده قرار می گیرد و باعث استفاده بهتر از توان زیرساخت شبکه می شود. یک نمونه دیگر در تصویر زیر نمایش داده شده است.

Image

اگر شبکه فوق را یک شبکه IP در نظر بگیریم شما نمی توانید تنها با تنظیم روتر A روتر C را مجبور به ارسال ترافیک از طریق مسیر پایین کنید و این روتر C است که تصمیم می گیرد که ترافیک را از مسیر بالا یا پایین ارسال کند. اما اگر مهندسی ترافیک MPLS را در این شبکه اجرا کنیم می توانیم ترافیک را از روتر A به روتر B از طریق مسیر پایین ارسال کنیم. مهندسی ترافیک روتر C را مجبور به ارسال ترافیک A به B از مسیر پایین می کند. این کار توسط MPLS امکان پذیر است چون از مکانیزم Label زدن استفاده می کند. در این مثال روتر A به عنوان نقطه ورودی شبکه MPLS ما است در نتیجه این روتر مسیر عبور ترافیک را مشخص می کند این عمل Source-Based Routing نیز نامیده می شود. Label که به بسته تویط روتر A زده می شود باعث می شود که بسته از مسیری که توسط روتر A مشخص کرده عبور کند و دیگر روترهای میانی نمی توانند مسیر آنرا تغییر دهند.
یکی دیگر از مزایای استفاده از مهندسی ترافیک MPLS امکان سریع مسیریابی مجدد یا (Fast ReRouting (FRR می باشد. FRR این قابلیت را به ما می دهد که در صورت بروز قطعی در لینک یا از دسترس خارج شدن روتر ، ترافیک label زده شده را دوباره مسیردهی کنیم این مسیریابی مجدد در کمتر از 50 ms صورت می گیرد که از سایر استانداردهای روز بسیار سریع تر است.

VPN Model :


VPN یک شبکه خصوصی مجازی است که روی یک بستر عمومی ایجاد می گردد. این شبکه خصوصی باید بتواند تمام سایت های مشتری را به یکدیگر متصل کند و به صورت کامل از VPNهای مرتبط با سایر مشتریان جدا باشد. معمولا هر VPN به یک سازمان که دارای چند سایت است اختصاص دارد و سایت های سازمان را از طریق VPN روی بستر عمومی Service Provider به یکدیگر متصل می کند.
Service Providerها می توانند دو نوع عمده VPN را به مشتریان خود ارائه دهند :

  1. Overlay VPN Model
  2. Peer-to-Peer VPN Model

 

Overlay VPN Model :


Service Provider در Overlay VPN بین روترهای مشتری در شبکه خود سرویس Point to Point یا مداری مجازی (Virtual Circuits) فراهم می کند. روت ها بین روترهای مشتری توسط لینک های ارائه شده توسط Service Provider تبادل می شود. روترها و سوئیچ های Service Provider داده های مشتری را در سرتاسر شبکه خود حمل می کنند و هیچگونه تبادل Route بین روتر مشتری و روتر Service Provider انجام نمی گیرد و این باعث می شود که روترهای Service Provider هرگز Routeهای مشتری را نبینند.
سرویس Point to Point می تواند در لایه یک ، دو و یا سه باشد. نمونه لایه یک آن TDM ، E1 ، E3 ، Sonet و SDH می باشد و نمونه لایه دو X.25 ، ATM و Frame Relay می باشد.
در تصویر زیر یک شبکه Overlay را نشان می دهد که بر روی بسته Frame Relay ایجاد شده است. سوئیچ های Frame Relay در شبکه Service Provider برای ایجاد مدار مجازی بین روترهای مشتری که در لبه شبکه Frame Relay قرار دارد تنظیم می گردند.

Image

در لایه سوم از دیدگاه روترهای مشتری آنها به صورت مستقیم به یکدیگر متصل هستند در شکل زیر از دیدگاه مشتری این ارتباط نمایش داده شده است.

Image

شبکه Overlay را می توان در لایه سوم ارائه داد و معمولا از GRE Tunnel برای ایجاد شبکه Overlay روی پروتکل IP استفاده می شود. این تونل ترافیک را با هدر GRE و یک هدر IP کپسوله می کند. هدر GRE برای مشخص شدن پروتکل انتقال استفاده می شود و هدر IP برای هدایت بسته ها در شبکه Service Provider مورد استفاده قرار می گیرد. در تصویر زیر یک شبکه Overlay با GRE Tunnel را نشان می دهد. یکی از مزایای استفاده از GRE Tunnel امکان هدایت ترافیک غیر IP است.

Image

نکته : امکان استفاده از IPsec در GRE Tunnel وجود دارد که با رمزنگاری داده ها باعث تامین امنیت آنها می شود.

در بخش بعدی Peer-to-Peer VPN Model را مورد بحث قرار می دهیم. موفق ، پیروز و itpro باشید.

تکنولوژی MPLS چیست ؟ – بخش اول

Multiprotocol Label Switching) MPLS) یک تکنولوژی انتقال است این تکنولوژی چندین سال است که به یک تکنولوژی معروف و محبوب تبدیل شده است. MPLS از یک مکانیزم Label زدن یا برچسب زدن برای ارسال بسته ها در شبکه استفاده می کند. در این مقاله می خواهیم این تکنولوژی MPLS را مورد بحث قرار دهیم.

Image

به طور کلی اگر بخواهیم عملکرد MPLS را شرح دهیم عمل سوئچینگ را با استفاده از مکانیزم Label گذاری در بستر روتینگ انجام می دهد. یعنی یک بسته در هنگام ورود به شبکه MPLS براساس آدرس IP مقصد label گذاری می شود و در طول مسیر در لایه دوم و براساس این label هدایت می شود تا به مقصد برسد.
MPLS در یک لایه خاص از OSI قرار نمی گیرد و عملکرد آن بین لایه دوم (Data link) و لایه سوم (Network) قرار می گیرد به همین خاطر آنرا به عنوان یک پروتکل لایه 2.5 معرفی می کنند.
همانطور که اشاره شده MPLS از مکانیزم Label گذاری روی بسته استفاده می کند. Label های MPLS بین روترها پخش می شوند و روترها با استفاده از این labelها می توانند یک نقشه از labelهای شبکه بدست آورند. این labelها به بسته های IP متصل می شوند و روترها را قادر می سازد که با استفاده از این labelها بدون در نظر گرفتن آدرس IP اقدام به ارسال بسته ها کنند. در MPLS بسته ها به وسیله Label switching بجای IP switching ارسال می شوند.
تکنولوژی label switching یک تکنولوژی جدید نیست و شبکه های Frame Relay و ATM برای ارسال فریم ها و cell ها از آن استفاده می کرده اند. در Frame Relay و ATM ، در هر hop از شبکه label تغییر می کند و این تفاوت عمده این دو تکنولوژی با ارسال در IP Packet است. زمانی که روتر یک بسته IP را ارسال می کند هیچ تغییری در آدرس مقصد بسته نمی کند. در واقعیت labelهای MPLS برای ارسال بسته های مورد استفاده قرار می گیرد و از آدرس IP استفاده نمی شود.

برخی مزایای استفاده از MPLS :


در اینجا به صورت خلاصه مزایای استفاده MPLS را در شبکه عنوان می کنیم :

  • استفاده از یک زیرساخت شبکه یکپارچه
  • بهتر از IP over ATM است
  • Border Gateway Protocol (BGP)-free core
  • بهینه شدن جریان ترافیک
  • مهندسی ترافیک
  • مدل peer-to-peer برای MPLS VPN

 

زیرساخت شبکه یکپارچه :


در MPLS ترافیک در هنگام ورود براساس مقصد label گذاری می شوند و از یک بستر عمومی عبور داده می شوند و این ویژگی یکی از مزایای بزرگ MPLS می باشد. یکی از دلایلی که IP به عنوان پروتکل شبکه جهانی انتخاب شد این است که بسیاری از تکنولوژی های دیگر را می توان از آن عبور داد.
استفاده از MPLS به همراه IP این امکان را به ما می دهد که هر چیزی را که بخواهیم منتقل کنیم. اضافه کردن label به بسته ها باعث می شود که بتوانیم در یک بستر MPLS پروتکل های غیر IP را منتقل کنیم. MPLS میتواند IPv4 ، IPv6 ، Ethernet ، HDLC ، PPP و دیگر تکنولوژی های لایه دو برای برای ما منتقل کند.
به ویژگی که هر نوع فریم لایه دو در بستر MPLS منتقل گردد Any Transport Over MPLS یا AToM گفته می شود. روترهای که ترافیک AToM را منتقل می کنند نیاز به اطلاع از محتوای آن ندارند و برای ارسال آن تنها نیاز به خواندن Label آن دارند. به زبان ساده می توان MPLS را یک روش ساده برای ارسال ترافیک پروتکل های مختلف در یک شبکه نامید.
به توجه به تعاریف بالا MPLS این امکان را به Service Provider می دهد که انواع پروتکل های مورد نیاز مشتریان خود را با استفاده از یک شبکه واحد انتقال دهد.

Better IP over ATM Integration :


در دهه 90 میلادی پروتکل IP توانست از سایر پروتکل های لایه سوم مانند AppleTalk ، IPX ، و DECnet پیشی بگیرد. IP یک پروتکل نسبتا ساده و فراگیر است. ATM به عنوان یک پروتکل لایه دوم نتوانست مطابق انتظار ظاهر شود و بیشترین موفقیت آن در استفاده به عنوان یک پروتکل WAN برای Service Provider ها بود.
روش های مختلف برای ادغام ATM با IP ارائه شد اما پیاده سازی و خطایابی این روش ها بسیار سنگین و پیچیده بود. یکی از دلایل بوجود آمدن MPLS جایگزینی یک روش جدید و بهتر برای IP over ATM بود.

BGP-Free Core :


زمانی که شبکه Service Provider می خواهد ترافیک را منتقل کند هر روتر باید به مقصد بسته نگاه کند. اگر بسته ها به خارج از شبکه Service Provider بخواهد ارسال شود این آدرس های خارجی باید در جدول مسیریابی همه روترها وجود داشته باشد. این آدرس های خارجی توسط BGP حمل می شوند مانند آدرس های شبکه مشتریان یا آدرس های شبکه اینترنت. این به این معناست که همه روترهای Service Provider باید BGP را اجرا کنند.
اما MPLS این امکان را می دهد که ارسال بسته به جای بررسی آدرس IP براساس Label صورت گیرد. این label اطلاعاتی است که به روترهای میانی نشان می دهد که بسته باید به کدام روتر edge ارسال شود. در نتیجه روترهای Core نیازی به داشتن اطلاعات IP برای ارسال بسته ها ندارند و این باعث می شود روتر های Core نیازی به اجرای BGP نداشته باشند.
اما روتر های لبه یا همان Edge Router ها همچنان برای ارسال بسته ها نیار به بررسی آدرس IP دارند در نتیجه این روترها باید BGP را اجرا کنند.
شکل زیر یک شبکه MPLS را نسان می دهد که روترهای Edge آن BGP را اجرا کرده اند :

Image

یک ISP را در نظر بگیرد که دارای 200 روتر است بدون MPLS باید روی تمام این روتر BGP را اجرا کند اما اگر در این شبکه MPLS پیدا سازی شود تنها روتر های Edge که به طور مثال 50 تا هستند نیاز به اجرای BGP دارند.
در شبکه های MPLS تمام روتر های Core ارسال بسته ها را بدون در نظر گرفتن آدرس IP و تنها با بررسی label بسته انجام می دهند و این باعث می شود که از بار اجرای BGP و پیچیدگی های آن رها شوند. جدول مسیریابی اینترنت یک جدول سنگین می باشد که عدم اجرای آن در روترهای Core باعث می شود که روتر به RAM و CPU کمتری نیاز داشته باشد.

در بخش بعدی مقاله سایر مفاهیم را مورد بحث قرار می دهیم.

پروتکل مسیریابی OSPF یا Open Shortest Path First چیست و چگونه استفاده می شود؟ – قسمت پنجم

در بخش های قبلی این مقاله با بسیاری از مفاهیم پروتکل مسیریابی ospf آشنا شدیم و برای درک بهتر آن نیز یک سناریو را به صورت عملی پیاده سازی کردیم تا با این مفاهیم آشنا شویم و حالا در این بخش می خواهیم چند مفهوم دیگر را نیز مورد بحث قرار دهیم . پس با ما همراه باشید.

Default Routes :


Default route یک نوع خاص از Summarization است که همه شبکه ها را با یک Route خلاصه سازی می کند. اینکار مزایای فراوانی دارد که به چند مورد آن اشاره می کنیم:

  • باعث می شود جدول مسیریابی کوچکی داشته باشیم.
  • از منابع روتر کمتر استفاده می شود.
  • روتر نیاز به نگه داری اطلاعات Routeهای خارجی را ندارد
  • کمتر شدن اجرای الگوریتم انتخاب بهترین مسیر

Default Route در OSPF به عنوان type 5 در نظر گرفته می شود. برای استفاده از Default route در OSPF می توان از چند روش مختلف استفاده کرد. که بهترین روش استفاده از دستور Default-information در خود پردازش OSPF می باشد. این دستور بدون استفاده از کلید always باعث می شود که Default route را که از یک منبع دیگر مثل static route را فرا گرفته ایم را در OSPF منتشر کند. در صورت استفاده از کلید always حتی اگر Default route در جدول مسیریابی وجود نداشته باشد نیز آنرا در OSPF منتشر می کند.
دستور استفاده از Default route :

Router(config)#router ospf 1
Router(config-router)#default-information originate [always]

 

کاربرد و عملکرد Stub Area :


در Area غیر backbone کاهش اطلاعات جدول مسیریابی یک امر ضروری است چون روترهای این Areaها بسیار اسیب پذیرند چون معمولا دارای سرعت و قدرت پایین تری هستند و همچنین دارای کمترین پهنای باند می باشند. این ویژگی ها باعث ایجاد نگرانی بابت وجود Routeهای زیاد در این Areaها می شود که می تواند عواقبی مانند Overload شدن روتر یا اشغال لینک های ارتباطی شود.
یک راه برای کاهش اطلاعات مربوط به مسیرها این است که یک Area را به عنوان Stub area انتخاب کنیم. زمانی که یک Area را به عنوان Stub Area تعیین می کنیم باعث می شود که روترهای ABR روت های Type 5 را فیلتر کنند و به جای آنها یک Default Route ارسال کنند. و اینکار باعث می شود که دیتابیس روترهای این Area فقط شامل روت های OSPF و یک Default Route باشد. در Stub Area نمی توانیم ASBR داشته باشیم. اما در صورتی که بخواهیم تعداد روت ها را کمتر کنیم می توانیم از Totally Stubby Area استفاده کنیم که اختصاصی سیسکو است در این حالت ABR تمام روت های Type 3,4,5 را فیلتر می کند و به جای آنها فقط یک Default Route ارسال کند که باعث می شود دیتابیس این روترها فقط شامل روت های داخلی آن Area و یک Default Route باشد.
برخی از محدودیت های Stub Area :

  • نمی تواند شامل Virtual Link باشد.
  • در این ناحیه نمی توان از ASBR استفاده کرد.
  • همه روترهای آن Area باید به عنوان Stub Area تعریف شوند.
  • Area 0 را نمی توان به عنوان Stub Area انتخاب کرد.

(Not-so-Stubby Area (NSSA نوع دیگر Stub Area می باشد. NSSA همانند Stub Area می باشد با این تفاوت که می توان در این ناحیه از ASBR استفاده کرد. در نتیجه در این ناحیه روت های خارجی (Type 7) توسط ASBR در این ناحیه منتشر می شوند و ABR با تبدیل این روت ها به Type 5 آنها را به دیگر ناحیه ها اعلام می کند.
نوع دیگر Totally NSSA می باشد که همانند Totally Stub Area می باشد با این تفاوت که در این ناحیه نیز می توان از ASBR همانند NSSA استفاده کرد.

Image

از دستورات زیر برای تعیین Stub Area استفاده می شود.
برای تعریف یک Area به عنوان Stub Area از دستور زیر:

Router(config)#router ospf 1
Router(config-router)#area 1 stub 

برای تعریف یک Area به عنوان Totally Stubby Area از دستور زیر:

Router(config)#router ospf 1
Router(config-router)#area 1 stub no-summary

برای تعریف یک Area به عنوان NSSA از دستور زیر:

Router(config)#router ospf 1
Router(config-router)#area 1 nssa 

برای تعریف یک Area به عنوان Totally NSSA از دستور زیر:

Router(config)#router ospf 1
Router(config-router)#area 1 nssa no-summary

 

Virtual Link :


در OSPF همه Areaها باید به Area 0 متصل باشند. اما در بعضی مواقع این امکان فراهم نیست. در این شرایط می توان با استفاده از Virtual Link این اتصال را به Area 0 انجام داد این اتصال از طریق یک Area دیگر به عنوان واسط انجام می گیرد.
چه زمانی از Virtual Link استفاده می شود:

  • زمانی که بین Area 0 و Area مورد نظر لینک مستقیم وجود ندارد.
  • زمانی که Area 0 و Area مورد نظر همجوار نیستند.

نکته : Virtual Link را به عنوان یک راه حل موقت در نظر بگیرد و نسبت به حل درست آن اقدام کنید.
نکته : برای ایجاد Virtual Link از Router ID استفاده می شود در نتیجه نحوی انتخاب Router ID را در نظر داشته باشید.

نحوی ایجاد Virtual Link :
همانطور که در تصویر زیر می بینید Area 2 به صورت مستقیم به Area 0 متصل نیست برای همین یک Virtual Link باید بین روتر R4 و R2 ایجاد کنیم برای ایجاد Virtual Link از Router ID استفاده می شود.

Image

با توجه به شکل و توضیحات داده شده علاوه بر تنظیمات مربوط به OSPF دستورات زیر را برای برقراری Virtual Link به صورت زیر وارد می کنیم:
روتر R2 :

R2(config)#router ospf 1
R2(config-router)#area 1 virtual-link 4.4.4.4

روتر R4 :

R4(config)#router ospf 1
R4(config-router)#area 1 virtual-link 2.2.2.2

امیدوارم که این مقاله مفید واقع شده باشد.

پروتکل مسیریابی OSPF یا Open Shortest Path First چیست و چگونه استفاده می شود؟ – قسمت چهارم

در بخش های قبلی با مفاهیم پروتکل OSPF آشنا شدیم و همینطور که قول داده بودیم در این بخش می خواهیم یک سناریو را پیاده سازی کنیم تا با این مفاهیم که تا این لحظه مطرح شد بیشتر آشنا شویم.

سناریو :


یک شرکت را در نظر بگیرد که دفتر مرکزی آن در تهران قرار دارد و تعدادی نمایندگی در سطح چند استان دارد می خواهیم برای برقراری ارتباط این دفاتر و مسیریابی از پروتکل OSPF استفاده کنیم.
در ابتدا لیستی از شعب و شبکه های آنها را تهیه می کنیم:

  • دفتر مرکزی : در تهران مستقر است و سرورهای شرکت دفتر مرکزی قرار دارند رنج IP شبکه LAN مورد استفاده در دفتر مرکزی 10.1.0.0/24 می باشد.
  • شعبه ولیعصر تهران : رنج شبکه مورد استفاده برای آن 10.1.1.0/24 می باشد.
  • شعبه کرج : رنج شبکه مورد استفاده برای آن 10.1.2.0/24 می باشد.
  • شعبه مشهد : رنج شبکه مورد استفاده برای آن 10.2.1.0/24 می باشد.
  • شعبه سبزوار : رنج شبکه مورد استفاده برای آن 10.2.2.0/24 می باشد.
  • شعبه قوچان : رنج شبکه مورد استفاده برای آن 10.2.3.0/24 می باشد.
  • شعبه اهواز : رنج شبکه مورد استفاده برای آن 10.3.1.0/24 می باشد.
  • شعبه خرمشهر : رنج شبکه مورد استفاده برای آن 10.3.2.0/24 می باشد.
  • شعبه آبادان : رنج شبکه مورد استفاده برای آن 10.3.3.0/24 می باشد.
  • شعبه اصفهان : رنج شبکه مورد استفاده برای آن 10.4.1.0/24 می باشد.
  • شعبه کاشان : رنج شبکه مورد استفاده برای آن 10.4.2.0/24 می باشد.
  • شعبه تبریز : رنج شبکه مورد استفاده برای آن 10.5.1.0/24 می باشد.

با استفاده از خطوط مخابراتی ارتباط بین شعب و دفتر مرکزی به این صورت که شهرستان ها به مرکز استان و از مرکز استان به دفتر مرکزی به صورتی که در نقشه می بینید متصل شده اند :

Image

به توجه به موقعیت شعب ، Areaبندی را براساس استان ها انجام می دهیم که به صورت زیر می شود.

Image

در ابتدا برای هر روتر IP مورد استفاده در شبکه LAN را تعریف می کنیم (در اینجا از اینترفیس Loopback ) استفاده می کنیم و IP پورت های WAN را مشخص می کنیم و سپس OSPF را روی آن فعال می کنیم به صورت زیر:
روتری دفتر مرکزی:

Markazi(config)#interface Loopback1
Markazi(config-if)#ip address 10.1.0.1 255.255.255.0
Markazi(config)#interface Serial0/0
Markazi(config-if)#ip address 172.16.3.1 255.255.255.0
Markazi(config)#interface Serial0/1
Markazi(config-if)#ip address 192.168.1.1 255.255.255.0
Markazi(config)#interface Serial0/2
Markazi(config-if)#ip address 192.168.2.1 255.255.255.0
Markazi(config)#interface Serial0/3
Markazi(config-if)#ip address 172.16.4.1 255.255.255.0
Markazi(config)#interface Serial0/4
Markazi(config-if)#ip address 172.16.2.1 255.255.255.0
Markazi(config)#interface Serial0/5
Markazi(config-if)#ip address 172.16.5.1 255.255.255.0
Markazi(config)#router ospf 1
Markazi(config-router)#network 10.1.0.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.2.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.3.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.4.0 0.0.0.255 area 0
Markazi(config-router)#network 172.16.5.0 0.0.0.255 area 0
Markazi(config-router)#network 192.168.1.0 0.0.0.255 area 0
Markazi(config-router)#network 192.168.2.0 0.0.0.255 area 0

روتر شعبه ولیعصر :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.1.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0

روتر شعبه کرج :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.1.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.1.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

روتر شعبه مشهد :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.2.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.22.1 255.255.255.0
Router(config)#interface Serial0/2
Router(config-if)#ip address 192.168.23.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.1.0 0.0.0.255 area 1
Router(config-router)#network 172.16.2.0 0.0.0.255 area 0
Router(config-router)#network 192.168.22.0 0.0.0.255 area 1
Router(config-router)#network 192.168.23.0 0.0.0.255 area 1

روتر شعبه سبزوار :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.22.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.22.0 0.0.0.255 area 1

روتر شعبه قوچان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.2.3.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.23.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.2.3.0 0.0.0.255 area 1
Router(config-router)#network 192.168.23.0 0.0.0.255 area 1

روتر شعبه اصفهان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.4.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.4.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.42.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.4.1.0 0.0.0.255 area 2
Router(config-router)#network 172.16.4.0 0.0.0.255 area 0
Router(config-router)#network 192.168.42.0 0.0.0.255 area 2

روتر شعبه کاشان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.4.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.42.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.4.2.0 0.0.0.255 area 2
Router(config-router)#network 192.168.42.0 0.0.0.255 area 2

روتر شعبه اهواز :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.3.2 255.255.255.0
Router(config)#interface Serial0/1
Router(config-if)#ip address 192.168.32.1 255.255.255.0
Router(config)#interface Serial0/2
Router(config-if)#ip address 192.168.33.1 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.1.0 0.0.0.255 area 3
Router(config-router)#network 172.16.3.0 0.0.0.255 area 0
Router(config-router)#network 192.168.32.0 0.0.0.255 area 3
Router(config-router)#network 192.168.33.0 0.0.0.255 area 3

روتر شعبه خرمشهر :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.2.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.32.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.2.0 0.0.0.255 area 3
Router(config-router)#network 192.168.32.0 0.0.0.255 area 3

روتر شعبه آبادان :

Router(config)#interface Loopback1
Router(config-if)#ip address 10.3.3.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 192.168.33.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.3.3.0 0.0.0.255 area 3
Router(config-router)#network 192.168.33.0 0.0.0.255 area 3

روتر شعبه تبریز :

outer(config)#interface Loopback1
Router(config-if)#ip address 10.5.1.1 255.255.255.0
Router(config)#interface Serial0/0
Router(config-if)#ip address 172.16.5.2 255.255.255.0
Router(config)#router ospf 1
Router(config-router)#network 10.5.1.0 0.0.0.255 area 5
Router(config-router)#network 172.16.5.0 0.0.0.255 area 0

تنظیمات مربوطه تمام شده و روترها همسایه شده و روت ها بین آنها رد و بدل شده در تصویر زیر با استفاده از دستور Show ip route جدول مسیریابی روتر دفتر مرکزی نمایش داده می شود.


در تصویر می بینید مسیرهایی که با حرف اختصار O نمایش داده می شود از طریق OSPF دریافت شده است.

Image

همچنین با دستور Show ip ospf neighbor لیست همسایه های روتر مرکزی را می بینید که در تصویر زیر نمایش داده می شود:

Image

همانطور که در تصویر می بینید RID روتر همان IP مربوط به اینترفیس Loopback می باشد.
همچنین در قسمت state وضعیت همسایگی را نشان می دهد که در حالت Full قرار دارد.
خط تیره بعد از Full نشان دهنده نوع شبکه PTP می باشد و در آن انتخاب DR و BDR نداریم. اگر با دستور زیر نوع شبکه را برای پورت سریال 2 روتر دفتر مرکزی و پورت سریال 0 روتر کرج را به حالت Broadcast قرار دهیم خروجی دستور بالا به شکل زیر خواهد شد و می بینید که روتر مرکزی به عنوان DR انتخاب شده است.

Image

همچنین سایر اطلاعات مانند اینترفیسی که از طریق آن با روتر مقابل همسایه شده ایم و IP روتر همسایه و مدت زمان مربوط به Dead را نشان می دهد.

Authentication :


جهت فعال سازی Authentication از دستورات زیر استفاده می کنیم:
در اینجا این قابلیت را فقط بین دو روتر مرکزی و ولیعصر به صورت زیر فعال می کنیم:
روتر ولیعصر :

Valiasr(config)#interface Serial 0/0
Valiasr(config-if)#ip ospf authentication message-digest
Valiasr(config-if)#ip ospf authentication-key 123

روتر مرکزی :

markazi(config)#interface Serial 0/1
markazi(config-if)#ip ospf authentication message-digest
markazi(config-if)#ip ospf authentication-key 123

با استفاده از دستور زیر می توانیم وضعیت Authentication را برای یک پورت ببینیم :

Markazi#show ip ospf interface serial 0/1

خروجی دستور فوق به صورت زیر است :

Image

امیدوارم که این سناریو برای درک بهتر این پروتکل مفید واقع شده باشد.

پروتکل مسیریابی OSPF یا Open Shortest Path First چیست و چگونه استفاده می شود؟ – قسمت سوم

در ادامه مقالات قبلی می خواهیم با سایر مفاهیم این پروتکل آشنا شویم

OSPF Neighbor States :


وضعیت های که روترها سپری می کنند تا همسایه شوند به صورت زیر است:

  • Down
  • Initialize
  • Two way
  • Exstart
  • Exchange
  • Loading
  • Full

 

شبکه های Point to Point :


در این حالت بین دو روتر یک لینک اختصاصی وجود دارد مانند اینترفیس سریال

Image

در این شبکه ها مراحل همسایگی و تبادل اطلاعات توپولوژی به صورت زیر است:

  • Down : هنوز OSPF روی روتر اجرا نشده و هیچ بسته ای در رابطه با OSPF ردوبدل نمی شود.
  • Initialize : در این وضعیت OSPF اجرا شده و روتر شروع به ارسال Hello به آدرس 224.0.0.5 که multicast است می کند.
  • Two way : در این وضعیت روتر یک Hello که حاوی RID خودش است دریافت می کند. در صورت تطبیق شرایط مورد نیاز همسایگی با روتر مقابل همسایه شده و به آن با قرار دادن RID روتر مقابل پاسخ می دهد در این مرحله ارتباط به صورت unicast انجام می شود.
  • Exstart : در این مرحله کسی که قرار است تبادل اطلاعات توپولوژی را شروع کند مشخص می شود که در اینجا کسی که RID بزرگتری دارد اینکار را شروع می کند.
  • Exchange : در این مرحله روتر انتخاب شده در مرحله قبل اقدام به ارسال یک بسته DBD می کند که شامل خلاصه ای از شبکه های متصل به آن روتر می باشد سپس روتر مقابل نیز اینکار را انجام می دهد و هر روتر بعد از دریافت بسته DBD یک بسته ACK به منظور تایید دریافت بسته ارسال می کند. اینکار توسط روتر مقابل نیز انجام می شود.
  • Loading : روتر که بسته DBD را دریافت کرد آنرا با شبکه هایی که دارد مقایسه می کند و برای شبکه هایی که آنها را ندارد توسط بسته LSR درخواست ارسال می کند که اطلاعات کامل آنها را می خواهد. روتر مقابل اطلاعات کامل را توسط یک بسته LSU ارسال می کند و بعد از دریافت LSU یک بسته ACK به منظور تایید دریافت ارسال می کند. این عمل توسط روتر مقابل نیز انجام می شود.
  • Full : حالا اطلاعات جدول توپولوژی کامل شده و هر روتر به صورت جداگانه الگوریتم SPF را اجرا می کنند و جدول مسیریابی خود را بروز می کنند.

 

شبکه های (Multi Access (Broadcast :


Multi Access لینک هایی هستند که به صورت اشتراکی مورد استفاده قرار می گیرند. مانند Ethernet

Image

در این نوع شبکه ها ارتباط و تبادل اطلاعات دو به دو انجام نمی شود و یک روتر به عنوان Designated Router یا DR انتخاب می شود و وظیفه بروز نگه داشتن همه روترها را دارد در این حالت DR یک نقطه حساس در شبکه است و اگر این روتر از کار بیافتد شبکه نیز مختل می شود برای جلوگیری از این مشکل یک روتر به عنوان Backup Designated Router یا BDR در نظر گرفته می شود و به طور دائم ، فعال و زنده بودن DR را چک می کند و در صورت بروز مشکل اطلاعات لازم برای DR شدن را دارد.
در شبکه های Multi Access همه روترها فقط با روتر DR و BDR مراحل برقراری و تبادل اطلاعات را که در شبکه های Point To Point گفته شد انجام می دهند و در این شبکه ها روترهای DROther بسته های خود را به آدرس 224.0.0.5 ارسال می کنند و 224.0.0.6 توسط DR برای ارسال بسته ها مورد استفاده قرار می گیرد.

  • نکته : بهتر است در انتخاب DR و BDR ما نقش داشته باشیم و بهترین روترها را برای اینکار انتخاب کنیم مثلا روترهایی که توانا بالاتری دارند یا به همه روترها لینک مستقیم دارند.
  • نکته : سایر روترها به عنوان DRother در نظر گرفته می شوند.

 

شبکه های NBMA :


این شبکه ها از یک مدیا مشترک استفاده می کنند ولی ترافیک به صورت مستقیم بین دستگاه ارسال می شود و ترافیک Broadcast در این شبکه نداریم در این شبکه ها امکان استفاده از OSPF وجود دارد و از مکانیزم DR و BDR بهره می گیرد ولی همسایگی باید به صورت دستی تعریف شود.

Image

 

شبکه های (Point to Multipoint (PTMP :


مکانیزم این شبکه ها برای OSPF همانند شبکه های Point to Point است.

Image

 

شبکه های (Point to Multipoint nonbroadcast (PTMNB :


مکانیزم این شبکه ها برای OSPF همانند شبکه های Point to Point است با این تفاوت که باید همسایگی به صورت دستی انجام گیرد.

نکاتی در پیاده سازی OSPF :


پیاده سازی OSPF نسبت به سایر پروتکل های مسیریابی مانند EIGRP نیازمند یک طرح و برنامه دقیق تر است چون طراحی OSPF شرایط و نیازهای خاص خودش را می طلبد. برای پیاده سازی OSPF شرایط زیر را در نظر بگیرد:

  • وضعیت فعلی شبکه : یک لیست از IP address های مورد استفاده ، انواع لینک ها و ارتباطات ، پهنای باندها ، تجهیزات موجود و … تهیه کنید.
  • اطلاعات مورد نیاز : در اینجا باید مشخص کنیم که از چه شماره Process برای OSPF استفاده شود ، RID بر چه اساس انتخاب شود ، چه روترهایی OSPF را اجرا کنند و …
  • IP Plan : همه جوانب را برای پیاده سازی یک طرح ایده ال برای سیستم آدرس دهی در نظر بگیرد.
  • طراحی سلسله مراتبی : OSPF نیاز به پیاده سازی سلسله مراتبی دارد. باید یک Area Backbone یا همان Area 0 در نظر گرفت و سایر Area ها باید به گونه ای طراحی شوند که به Area 0 به صورت مستقیم متصل باشند.
  • انتخاب تجهیزات : روترهایی را به عنوان ABR ، ِDR و … انتخاب کنید که به لحاظ توانایی و شرایط بتوانند وظایف خود انجام دهند.
  • آینده نگری : گسترش و تغییرات شبکه در آینده را در نظر بگیرد.
  • تهیه گزارش و برنامه پایان کار : در انتها شرایط ، مراحل و … پیاده سازی OSPF را به صورت Document تهیه کنید تا در صورت نیاز بتوانید از آنها به عنوان مرجع استفاده کنید.

 

OSPF Summarization :


در OSPF علاوه بر اینکه خلاصه سازی مسیر ها باعث کاهش تعداد رکورد های جدول مسیریابی می شود یک ویژگی بسیار مهم دیگر دارد که به آن می پردازیم.
زمانیکه در Routeها تغییری به وجود می آید باعث می شود که الگوریتم SPF دوباره اجرا شده و باعث درگیر شدن CPU و Ram روترها گردد. حال یک شبکه بزرگ را در نظر بگیرد که دارای شبکه های فراوان و تغییرات بسیار است و این باعث می شود که روترها همیشه درگیر اجرای الگوریتم SPF باشند برای جلوگیری از این مشکل و هدر رفتن منابع از قابلیت Summarization استفاده می کنیم که باعث می شود تغییرات Routeها کمتر مبادله شوند و در هنگام تغییرات فقط روترهای داخل آن Area درگیر اجرای الگوریتم SPF شوند.

دو نوع Summarzation داریم :

    • Inter-area (LSA Type 3) Route Summarization : این روت توسط روترهای ABR ایجاد می شود و با دستور زیر استفاده می شود:
Router(config)#router ospf 1
Router(config-router)#area 1 range 172.16.0.0 255.240.0.0
    • External (LSA Type 5) Route Summarization : این روت توسط روترهای ASBR ایجاد می شود و با دستور زیر استفاده می شود:
Router(config)#router ospf 1
Router(config-router)#summary-address 192.168.0.0 255.255.0.0

 

OSPF Authentication :


در پروتکل OSPF امکان استفاده از ماکنیزم احراز هویت(Authentication) وجود دارد با استفاده از این قابلیت شبکه را در برابر اتصال روترهای غیرمجاز به شبکه OSPF و هرگونه تغییرات محفوظ نگه می دارد. در نتیجه هر روتر در هنگام دریافت بسته های OSPF ابتدا هویت آنها را تایید می کند.
به دو صورت زیر امکان استفاده از Authentication دارد :

  • Clear Text : در این حالت احراز هویت بودن رمز نگاری انجام می گیرد درنتیجه در صورتی که بسته ها اگر Sniff شوند امکان دستیابی به پسورد وجود دارد.
  • MD5 : در این حالت برای افزایش امنیت از مکانیزم رمزنگاری نیز استفاده می شود.

مکانیزم احرازهویت را به دو صورت زیر می توان پیاده سازی کرد:

    • در اینترفیس مورد نظر با استفاده از دستور زیر:
Router(config)#interface fastethernet 0/1
Router(config-if)#ip ospf authentication-key 123
Router(config-if)#ip ospf authentication message-digest
    • در حالت دوم احراز هویت را برای یک Area فعال می کنیم:
Router(config)#router ospf 1
Router(config-if)#ip ospf authentication message-digest

سپس روی اینترفیس های مورد نظر کلید را مشخص می کنیم.

Passive Interface :


فعال کردن این ویژگی روی یک اینترفیس باعث می شود که دیگر روی آن اینترفیس بسته Hello ارسال نشود و دیگر از طریق این اینترفیس نمی تواند با روتری دیگر همسایه شود. روی پورت هایی که انتظار نداریم روی آنها همسایگی داشته باشیم مانند اینترفیس متصل به LAN بهتر است این ویژگی فعال شود.
برای اینکار از دستور زیر استفاده می شود:

Router(config)#interface fastethernet 0/0
Router(config-if)#passive-interface

 

تنظیمات ساده OSPF :


برای اجرای OSPF کافیست که در Config mode دستور زیر را وارد کنید:

Router(config)#router ospf 5
  • نکته : در اینجا عدد 5 شماره process می باشد که می توان روی یک روتر چند OSPF اجرا کرد.
  • نکته : این شماره می تواند روی روتر های مختلف متفاوت باشد.

سپس با دستور زیر اینترفیس هایی که می خواهیم به بقیه اعلام می کنیم. در انتهای دستور با عبارت area مشخص می کنیم این اینترفیس در کدام area قرار دارد:

Router(config-Router)#network 192.168.1.0 0.0.0.255 area 0
    • نکته : با دستور زیر نیز می توانیم عمل فوق را از طریق اینترفیس انجام دهیم:
Router(config)#interface fastethernet 0/0
Router(config-if)#ip ospf 5 area 0

در صورتی که بخواهیم یک اینترفیس Loop Back بسازیم از دستورات زیر استفاده می کنیم:

Router(config)# interface loopback 0
Router(config-if)# ip address 10.0.0.1 255.255.255.255

  • نکته : استفاده از Loopback به این لحاظ که یک اینترفیس مجازی است و مانند اینترفیس های فیزیکی امکان قطع شدن ندارد برای RID مناسب است و علاوه بر آن امکان ping و trace را به ما می دهد که برای troubleshooting مفید است.

در صورتی که بخواهیم RID را به صورت دستوری مشخص کنیم به صورت زیر عمل می کنیم :

Router(config)# router ospf 5
Router(config-router)# router-id 10.0.0.1

در صورتی که بخواهیم پروسه OSPF را ریست کنیم از دستور زیر استفاده می کنیم:

Router#clear ip ospf process

جهت دیدن نوع شبکه می توانیم از دستور زیر استفاده کنیم:

Router#show ip ospf interface

اگر بخواهیم نوع شبکه را مشخص کنیم از دستور زیر استفاده می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip ospf network point-to-multipoint

شبکه هایی که از Broadcast پشتیبانی نمیکنند مانند NBMA باید همسایگی در آنها به صورت دستی انجام پذیرد که به صورت زیر است:

Router(config)#router ospf 5
Router(config-router)#neighbor 192.168.1.2

برای بررسی و دیدن تنظیمات و خطایابی از دستورات زیر استفاده می کنیم:

Router#show ip ospf adjacencies
Router#show ip ospf neighbor
Router#show ip route
Router#show ip route ospf
Router#show ip protocol
Router#show ip ospf
Router#show ip ospf interface
Router#debug ip ospf packet

در قسمت بعدی این سری آموزشی یک سناریوی عملی را پیاده سازی خواهید کرد تا با مفاهیمی که تا الان گفته شد بهتر آشنا شویم.
موفق ، پیروز و Itpro باشید.

پروتکل مسیریابی OSPF یا Open Shortest Path First چیست و چگونه استفاده می شود؟ – قسمت دوم

در قسمت قبل با برخی از مفاهیم پروتکل OSPF مانند ویژگی ها ، ساختار ، جداول ، نحوی محاسبه Cost و … آشنا شدیم در این قسمت می خواهیم در رابطه با سایر مفاهیم این پروتکل قدرتمند صحبت کنیم .

(Link State Advertisements (LSA :


هر روتر برای هر Area یک دیتابیس تحت عنوان (link-state database (LSDB ایجاد می کند که حاوی اخرین LSA دریافتی می باشد. در تعریف دیگر OSPF با کمک LSA از توپولوژی شبکه آگاه می شود و دیتابیس خود را براساس آن می سازد.

عملکرد LSA :
هر LSA دارای یک شماره و یک طول عمر است که به طور پیش فرض 30 دقیقه می باشد. زمانی که یک LSA دریافت می شود با دیتابیس LSDB مقایسه می شود. اگر LSA جدید بود به دیتابیس اضافه می شود و الگوریتم SPF اجرا می شود. اگر LSA از یک Router ID که قبلا در دیتابیس موجود است باشد Sequence Number آن مقایسه می شود و اگر قدیمتر بود از آن صرفه نظر می شود. اگر LSA قدیمی تر باشد LSA جدیدتر که در حافظه موجود است برای فرستنده LSA ارسال می شود.
Sequence Number 32 بیتی می باشد. اولین مقدار Sequence Number برابر 0x80000001 می باشد.Sequence Number به یکی از دو دلیل زیر تغییر می کند:

  • زمانی که یک Route اضافه یا حذف می شود.
  • طول عمر LSA تمام شود.

با استفاده از دستور زیر می توانید می توانید طول عمر و Sequence Number را ببینید :

Router#show ip ospf database

انواع LSA :
OSPF برای Advertise از LSA متفاوت برای Route مختلف مثل Area داخلی یا خارجی استفاده می کند. بعضی از آنها با نماد خاصی در جدول مسیریابی نمایش داده می شوند. در جدول زیر انواع LSA را می بینیم:

Image

 

  • Type 1 : Router LSA ، در این نوع روترهای یک LSA تولید و به وسیله آن وسیله لینک خود را در Area اعلام می کنند در این حالت تمام روترهای Area اینکار را انجام می دهند.
  • Type 2 : Network LSA ، روتری که نقش DR را دارد این LSA را تولید می کند و در Area آنرا پخش می کند.
  • Type 3 : Summary LSA ، توسط روترهای ABR تولید می شود و شامل مسیرهایی است که از طریق ABR می توان به آن رسید.
  • Type 4 : Summary LSA ، توسط ABR تولید می شود و جهت اگاه سازی از وجود ASBR بکار می رود یعنی مسیر رسیدن به ASBR را مشخص می کند.
  • Type 5 : External LSA ، توسط ASBR تولید می شود و شامل Routeهای خارجی می شود و به وسیله این نوع LSA به بقیه روترها اعلام می شود.
  • Type 6 : Multicast LSA ، در عملیات Multicast مربوط به OSPF استفاده می شود.
  • Type 7 : NSSA LSA ، در ناحیه NSSA ، Route خارجی توسط ASBR در همان Area توسط این نوع LSA اعلام می شود و این LSA به وسیله ABR به نوع 5 تغییر و اعلام می شود.

 

مفهوم (Router ID (RID :


هر روتر در OSPF یک شناسه 32 بیتی دارد که به یکی از روش های زیر قابل مشخص شدن است:

  • توسط دستور تعیین شود.
  • بزرگترین اینترفیس Loop Back روتر به عنوان RID در نظر گرفته می شود.
  • بزرگترین اینترفیس را در نظر می گیرد (اینترفیس با در حالت up باشد).

نکته : اگر RID را بعد از فعال شدن OSPF تغییر دهیم همان RID قبلی استفاده می شود مگر اینکه پروسه OSPF را Reset کنیم.
نکته : بهتر است که RID را براساس مقادیری تعیین کنیم که نشان دهنده آن روتر باشد تا در زمان های مانیتورینگ و خطایابی با استفاده از این RID متوجه شویم که منظور کدام روتر است.

بسته های مورد استفاده در OSPF :


OSPF برای برقراری ارتباط همسایگی و نگه داشتن آن از پیام هایی تحت عنوان OSPF Packet استفاده می کند. OSPF از پنج نوع بسته استفاده می کند و برای انتقال آنها از UDP یا TCP استفاده نمی کند و به صورت مستقیم روی پروتکل IP آنها با استفاده از OSPF Header ارسال می کند. یکی از فیلد های Header نشان دهنده نوع بسته می باشد. پنج نوع بسته مورد استفاده OSPF به شرح زیر است:

  • Hello : جهت شناسایی همسایه و ماکنیزمی به منظور اعلام حضور
  • (Database Description (DBD : یک خلاصه از شبکه هایی که دارد را به وسیله این بسته اعلام می کند.
  • (Link State Request (LSR : براساس اطلاعات دریافتی از بسته DBD از روتر مقابل اطلاعات کامل شبکه هایی را که در مورد آنها اطلاعات ندارد را درخواست می کند.
  • (Link State Update (LSU : با استفاده از این بسته به درخواست LSR پاسخ می دهد در واقع اطلاعات کامل شبکه های درخواستی را ارسال می کند.
  • (Link State Acknowledgment (LSAcK : تایید دریافت برای همه بسته های OSPF غیر از بسته های Hello

نکته : ترافیک OSPF به صورت Multicast به دو آدرس 224.0.0.5 و 224.0.0.6 ارسال می شود که 224.0.0.6 توسط روترهای DR و 224.0.0.5 توسط باقی روترها مورد استفاده قرار می گیرد.

مراحل اجرای OSPF :


  1. تشکیل جدول همسایگی
  2. تشکیل جدول توپولوژی
  3. اجرای الگوریتم SPF و بروز رسانی جدول مسیریابی

 

مراحل ایجاد همسایگی :


در OSPF در ابتدا باید با روترهای مجاور همسایه شد و اطلاعات آنها در جدول همسایگی قرار گیرد که به دو دلیل زیر انجام می گیرد:

  • از فعال و زنده بودن روتر همسایه مطمئن شود.
  • شرایط همسایگی بین دو روتر بررسی شود.

نکته : تشکیل همسایگی در OSPF توسط بسته های Hello انجام می گیرد. هر 10 ثانیه یکبار این بسته ها ارسال می شوند و اگر 40 ثانیه (Dead Time) از همسایه خود Hello دریافت نکند همسایه خود را غیرفعال و مرده درنظر می گیرد.

پارامترهایی که برای همسایگی مورد بررسی قرار می گیرد:


  • داشتن Hello interval برابر
  • داشتن Dead interval برابر
  • داشتن شماره Area یکسان
  • داشتن Sunbnet mask یکسان
  • داشتن Subnet number یکسان
  • Authentication مشابه
  • نداشتن RID برابر
  • Stub area flag

 

نحوی تبادل اطلاعات Topology :


در شبکه های زیر این تبادل اطلاعات با کمی تفاوت انجام می شود:

  • شبکه های Point to Point
  • شبکه های (Multi Access (Broadcast
  • شبکه های NBMA
  • شبکه های (Point to Multipoint (P2MP
  • شبکه های (Point to Multipoint nonbroadcast (P2MNB)پ

نکته : از روی نوع لینک امکان تشخیص شبکه فراهم می شود به طور مثال Fastethernet به عنوان یک شبکه Multi Access و Serial به عنوان یک شبکه Point to Point در نظر گرفته می شود.

مفهوم DR و BDR و نحوی انتخاب آنها :


در شبکه هایی که بستر ارتباطی بین روترهای شبکه مشترک است انجام عمل همسایگی و تبادل اطلاعات بین همه ارتباط باعث ایجاد بار زیاد و درگیر کردن تجهیزات می شود برای جلوگیری از این مشکل ، ارتباط و تبادل اطلاعات دو به دو انجام نمی شود و یک روتر به عنوان Designated Router یا DR انتخاب می شود و وظیفه بروز نگه داشتن همه روترها را دارد در این حالت DR یک نقطه حساس در شبکه است و اگر این روتر از کار بیافتد شبکه نیز مختل می شود برای جلوگیری از این مشکل یک روتر به عنوان Backup Designated Router یا BDR در نظر گرفته می شود و به طور دائم ، فعال و زنده بودن DR را چک می کند و در صورت بروز مشکل اطلاعات لازم برای DR شدن را دارد.
به طور ساده می خواهیم تعریفی از DR داشته باشیم می گویم DR را به عنوان ریشه یک درخت در نظر بگیرد که همه روترها (شاخه ها) به آن متصل می شوند و از طریق آن اطلاعات را ردوبدل می کنند.
به ترتیب براساس یکی از شرایط زیر DR انتخاب می شود:

  • روتری که دارای Priority بالاتر است.
  • روتری که دارای RID بالاتری است.

نکته : همین شرایط برای برای انتخاب BDR نیز استفاده می شود.
نکته : Priority می تواند بین 0 تا 255 مقدار بگیرد و پیش فرض آن 1 می باشد.
نکته : اگر Priority یک روتر 0 باشد به عنوان DR یا BDR انتخاب نمی شود.
نکته : انتخاب DR و BDR غیر رقابتی است یعنی یکبار این انتخاب انجام می شود و حتی یک روتر با Priority بهتر در شبکه حضور پیدا کند باز هم همان روترهای قبلی به عنوان DR و BDR خواهند بود مگر اینکه پروسه OSPF ریست شود.

سایر مفاهیم این پروتکل را در قسمت بعدی توضیح خواهم داد. موفق ، پیروز و سربلند باشید.

پروتکل مسیریابی OSPF یا Open Shortest Path First چیست و چگونه استفاده می شود؟ – قسمت اول

(Open Shortest Path First (OSPF یکی دیگر از پروتکل های خانواده IGP می باشد که توسط EITF به عنوان یک استاندارد عمومی ارائه شد. این پروتکل قدرتمند به این دلیل طراحی شد که پروتکل RIP توانایی کار کردن در شبکه بزرگ را نداشت. این پروتکل برای شبکه های IP طراحی شد و از Subnettingپشتیبانی می کند.

Image

پروتکل OSPF در دسته Link State قرار می گیرد یکی از وظایف پروتکل های Link State ایجاد یک دیتابیس از ساختار شبکه می باشد و برای پیدا کردن بهترین مسیر از الگوریتمی به نام SPF بهره می گیرد. پروتکل OSPF نسبت به سایر پروتکل های مسیریابی اطلاعات بیشتری در مورد ساختار شبکه بدست می آورد که باعث می شود تصمیم گیری بهتری برای مسیریابی داشته باشد.
روتر هایی که OSPF را اجرا می کنند بسته هایی تحت عنوان Hello را با روتر های مجاور خود (روتر همسایه) تبادل می کنند و به این وسیله (Router ID (RID و Cost را بدست می آورد و اطلاعات بدست آمده را در جدول Neighbor خود نگه می دارد. سپس روتر اقدام به ایجاد (Link State Advertisements (LSA مناسب می کند این LSA شامل اطلاعات مانند RID ، Cost هر یک از همسایه و … می باشد. روترها این LSA را در اختیار همسایه های خود قرار می دهند و روترها این اطلاعات را در جدولی به نام (Link State Database (LSDB نگه داری می کنند و در نهایت با استفاده از الگوریتم SPF بهترین مسیرها را انتخاب می کنند.

ویژگی های OSPF :


  • IP Subnetting
  • Authentication
  • Fast Converges
  • Partial Update
  • Summarization
  • Multicast
  • IP Protocol 89
  • Administrative Distance 110

 

جدول های OSPF :


  • Topology Table
  • Neighbor Table

 

ساختار OSPF :


مجموعه روترهایی که OSPF را اجرا می کند به بخش هایی تحت عنوان Area تقسیم می شوند. یک شبکه OSPF باید یک Area 0 داشته باشد و علاوه بر آن Area 0 می تواند Areaهای دیگری نیز داشته باشد. الگوریتم SPF در هر Area اجرا می شود و همچنین Routeهای ناحیه ای بین Areaها ردوبدل می شوند.
در OSPF دو سطح وجود دارد:

  • Area 0 که به عنوان ناحیه انتقال طراحی شده است و Area های دیگر به آن متصل می شوند.
  • Areaها دیگر باید به صورت مستقیم به Area 0 متصل شوند و از طریق Area 0 به دیگر Areaها دسترسی پیدا می کنند.

در هر Area روترها باید دیتابیس یکسانی داشته باشند. به طور معمول هر Area حداکثر 50 تا 100 روتر می تواند داشته باشد. که به شرایط شبکه بستگی دارد. در شکل زیر یک شبکه که شامل 5 روتر است را به ما نشان می دهد و این 5 روتر در سه ناحیه ، Area 0 , Area 1 , Area 2 قرار گرفته اند.

Image

 

شبکه OSPF را به چند ناحیه تقسیم کردن مزایای زیر را به همراه دارد:


  • به حداقل رساند تعداد رکوردهای جدول مسیریابی
  • کنترل شدن ارسال LSA در هر ناحیه
  • به حداقل رساندن تاثیر تغییرات در شبکه
  • اجرای مدل سلسه مراتبی در طراحی شبکه

 

انواع Areaهای موجود:


  • Backbone Area : همان Area 0 است که تمام Areaها دیگر باید به آن متصل شوند.
  • Regular area : Areaهای غیر Area 0 که دیتابیس آنها شما هر دو مسیرهای داخلی و خارجی است.
  • Stub area : دیتابیس این Areaها فقط شامل مسیرهای داخلی و یک Default Route می باشد.
  • Totally Stubby Area : اختصاصی شرکت سیسکو می باشد و دیتابیس آن شامل Routeهای Area خودش و یک Default Route می باشد.
  • (Not-so-stubby area (NSSA : دیتابیس آن شامل Routeهای داخلی و مسیرهای Redistributed شده و Default Route می باشد.
  • Totally NSSA : اختصاصی شرکت سیسکو است دیتابیس آن شامل Routeهای Area خودش و مسیرهای Redistributed شده و Default Route می باشد.

 

نقش های که روتر در OSPF می تواند داشته باشد:


  • Internal Router : یک روتر داخلی تمام اینترفیس ها آن در یک Area قرار دارد در شبکه بالا روتر های 1 و 2 و 5 به عنوان روتر داخلی محسوب می شوند.
  • Backbone Router : روتر Backbone حداقل یک اینترفیس آن به Area 0 متصل است در شکل بالا روترهای 3 و 4 و 5 به عنوان روتر Backbone محسوب می شوند.
  • (Area Border Router (ABR : روترهای که به دو یا چند Area متصل باشند در شکل بالا روترهای 3 و 4 به عنوان روتر ABR محسوب می شوند. ABRها مرز ارسال LSA را مشخص می کنند و می توانند Summarization را برای ما انجام دهند و یا به عنوان Default Route معرفی شوند. این روترها برای هر Area که به آن متصل است یک دیتابیس ایجاد می کند. در واقع ABRها Area مختلف را به یکدیگر متصل می کنند.
  • (Autonomous System Boundary Router (ASBR : این روترها از یک سمت به شبکه OSPF و از طرف دیگر به شبکه دیگر متصل است در شکل بالا روتر 3 به عنوان روتر ASBR شناخته می شود. چون از یک سمت به شبکه OSPF و از سمت دیگر به یک شبکه EIGRP متصل است. ASBR وظیفه اتصال شبکه OSPF را به دیگر شبکه های دارد.

نکته : یک روتر می تواند چند نقش داشته باشد.

نحوی محاسبه Metric در OSPF :


در OSPF برای محاسبه Metric از عبارتی تحت عنوان Cost یا هزینه استفاده می شود کمترین مقدار Cost در مسیر به عنوان Cost مسیر در نظر گرفته می شود. به طور مثال مسیر به رسیدن به یک مقصد از چند اینترفیس عبور می کند که همگی آنها دارای پهنای باند 100 Mbps هستند غیر از یکی که دارای پهنای باند 10 Mbps است برای این مسیر Cost محاسبه شده برای اینترفیس 10 Mbps در نظر گرفته می شود.
به طور پیش فرض سیسکو برای محاسبه Cost از یک پهنای باند مرجع که برابر 100 Mbps است استفاده می کند و این پهنای باند مرجع را بر پهنای باند مورد نظر تقسیم می کند به طور مثال ، Cost یک اینترفیس با پهنای باند 10 Mbps برابر با 10 خواهد شود. فرمول محاسبه Cost به صورت زیر است :

Image

عدد بدست آمده هرچه پایین تر باشد نشان دهنده بهتر بودن اینترفیس است.
نکته : با توجه به فرمول ، سرعت اینترفیس اگر از 100 Mbps بیشتر باشد نتیجه بدست آمده از آن تفاوتی نمی کند. در نتیجه پهنای باند 100 Mbps , 1 Gbps , 10 Gbps دارای Cost برابر هستند و دلیل آن پهنای باند مرجع که برابر 100 Mbps است. در صورتی که بخواهیم این پهنای باند مرجع را تغییر دهیم از دستور زیر استفاده می کنیم:

Router(config)#router ospf 1
Router(config-router)#auto-cost reference-bandwidth 1000

همچنین می توانیم Cost یک اینترفیس را به صورت دستی مشخص کنیم که می تواند عددی بین 1 تا 65535 برای آن در نظر گرفت با استفاده از دستور زیر:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip ospf cost 10

در بخش بعدی سایر مفاهیم این پروتکل را مورد بحث قرار می دهیم. موفق و پیروز باشید.

NAT چیست ؟ و چگونه از آن در تجهیزات سیسکو استفاده کنیم !

IPv4 نسخه چهارم پروتکل اینترنت نسبت به تقاضای فعلی شبکه به لحاظ تعداد IP محدود می باشد. به همین دلیل امکان درنظر گرفتن IP برای تمام تجهیزاتی که به اینترنت می خواهند متصل شود وجود ندارد. علاوه بر این محدودیت ، استفاده از IP های معتبر موجود در اینترنت نیاز به پرداخت هزینه است.
NAT) Netwrok Address Translate) برای برطرف شدن این مشکلات ارائه شد. در شبکه های محلی از Private IP استفاده می شود و برای شبکه تعداد محدودی IP معتبر (Public)گرفته می شود و با استفاده از سرویس NAT ارتباط دستگاه ها به اینترنت برقرار می شود.

Image

NAT یک IP به IP دیگر را تبدیل می کند یا عبارتی Private IP را به Public IP تبدیل می کند. به طور مثال یک شبکه را در نظر بگیرد که دارای 20 دستگاه است که می خواهند از اینترنت استفاده کنند با استفاده از سرویس NAT به جای اینکه برای هر دستگاه یک Public IP تهیه شود کلا یک Public IP تهیه می شود و برای دستگاه ها Private IP در نظر گرفته می شود و این دستگاه ها با استفاده از یک Public IP به اینترنت متصل می شوند. با اینکار در مصرف IP و هزینه صرفه جویی می شود.

رنج های Private IP :


  • 10.0.0.0 تا 10.255.255.255
  • 172.16.0.0 تا 172.31.255.255
  • 192.168.0.0 تا 192.168.255.255

 

برخی از موارد مورد استفاده NAT :


  • صرفه جویی در مصرف IP و هزینه
  • زمانی که بخواهیم IP را به دلایلی عوض کنیم
  • زمانی که شبکه داخلی از Private IP استفاده می کند.
  • برقراری ارتباط بین دو شبکه که دارای رنج IP یکسانی هستند.
  • نخواهیم رنج IP که در شبکه مورد استفاده قرار می گیرد از بیرون دیده شود.
  • زمانی که مقصد ، رنج IP داخلی شبکه ما را نمی شناسد.

 

سرویس ها و ویژگی هایی که با NAT مشکل دارند:


  • ناسازگاری با برخی از پروتکل ها : برخی از پروتکل ها IP آدرس مورد استفاده را در لایه هفتم نیز استفاده می کنند که باعث ایجاد مشکل می شود.
  • برخی از پروتکل های رمزنگاری و احرازهویت : یکی از مسائل در رمز نگاری و احراز هویت جلوگیری از تغییر بسته ها در حین ارسال می باشد.
  • Log گیری و گزارش گیری : با توجه به تغییر IP بررسی عملکرد و گزارشگیری مشکل است.

 

مفاهیم NAT :


Inside Local Address : آدرس هایی که برای شبکه داخلی مورد استفاده قرار می گیرد.(Private IP)
Inside Global Address : آدرس هایی که دستگاه های داخلی شبکه با آن از بیرون دیده می شوند. (Public IP)
Outside Local Address : آدرسی هایی که دستگاه های داخل شبکه ، دستگاه های خارج از شبکه را با آن می بینیم و می تواند آدرس Private باشد. نکته ای که وجود دارد این آدرس از طریق شبکه داخلی قابل مسیریابی است.
Outside Global Address : آدرس های Public مربوط به دستگاه های بیرون از شبکه ، که ما با آنها ارتباط برقرار می کنیم مانند Public IP سرور سایت Iitpro

کاربردهای اصلی NAT :


  • Source NAT : امکان ایجاد ارتباط یک دستگاه که دارای Private IP است را به اینترنت فراهم می کند.
  • Destination NAT : امکان ایجاد ارتباط به یک دستگاه که دارای Private IP است را از اینترنت فراهم می کند.

 

انواع NAT :


  • Static NAT
  • Dynamic NAT
  • (Overloaded (PAT

 

Static NAT :


در این روش یک آدرس Private را تبدیل به یک آدرس Public می کند یا به عبارتی یک دستگاه از شبکه داخلی به یک IP از شبکه خارجی تبدیل می شود.

Image

با توجه به تصویر فوق Static NAT را پیاده سازی می کنیم:
با استفاده از دستور زیر مشخص می کنیم که IP 192.168.1.5 به 5.5.5.1 تبدیل شود.

Router(config)#ip nat inside source static 192.168.1.5 5.5.5.1

سپس شبکه را به دو بخش inside و outside تقسیم می کنیم و دستورات زیر را روی اینترفیس مربوطه وارد می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations
Image

 

Dynamic NAT :


در این روش یک pool (رنج) از آدرس های Public را به یک رنج از Private IP شبکه داخلی اختصاص می دهیم. در این حالت تعداد IPهای داخلی و خارجی باید برابر باشد.

Image

در ابتدا با یک ACL مشخص می کنیم که چه بسته هایی اجازه NAT شدن را دارند.

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
  • نکته : NAT کردن براساس پارامترهای دیگر مانند پروتکل ، اینترفیس ، مقصد و … امکان پذیر است برای این حالت ، به جای Standard ACL ازExtended ACL استفاده می کنیم.

یک pool تعریف می کنیم و Public IP ها را در آن مشخص می کنیم.

Router(config)#ip nat pool itpro 5.5.5.1 5.5.5.3 prefix-length 24

ACL تعریف شده را به NAT اختصاص می دهیم

Router(config)#ip nat inside source list 1 pool itpro

سپس شبکه را به دو بخش inside و outside تقسیم می کنیم و دستورات زیر را روی اینترفیس مربوطه وارد می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations
Image

 

(Overloaded (PAT :


این روش مشابه Dynamic NAT می باشد با این تفاوت که به تعداد دستگاه هایی که می خواهند از اینترنت استفاده کنند نیاز به IP نداریم و تعداد می تواند کمتر و یا حتی یک عدد باشد.

Image

دستورات اجرای این روش مشابه Dynamic می باشد فقط یک تفاوت کوچک دارد:

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#ip nat pool itpro 5.5.5.1 5.5.5.3 prefix-length 24

در اینجا کلمه overload را به انتهای دستور اضافه می کنیم:

Router(config)#ip nat inside source list 1 pool itpro overload
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

برای مشاهده وضعیت NAT از دستور زیر استفاده کنید:

Router#show ip nat translations
Image

 

Overlapping NAT :


بعضی از مواقع می خواهیم ارتباط بین دو شبکه که دارای رنج IP یکسانی هستند را برقرار کنیم برای اینکار از Overlapping NAT به صورت زیر استفاده می کنیم:

Image

همانطور که در تصویر می بینید سرور1 و سرور2 هر دو دارای آدرس 192.168.1.11/24 هستند و هر کدام در یک شبکه قرار دارند. در این سناریو می خواهیم ارتباط این دو سرور را با استفاده از NAT برقرار کنیم:
برای پیاده سازی این سناریو از دستورات زیر استفاده می کنیم که مشابه Static NAT می باشد.
در ابتدا روی روتر R1 :

Router(config)# ip nat inside source static 192.168.1.11 192.168.12.11
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

سپس روی روتر R2 :

Router(config)# ip nat inside source static 192.168.1.11 192.168.12.12
Router(config)#interface fastethernet 0/0
Router(config-if)#ip nat inside
Router(config)#interface fastethernet 0/1
Router(config-if)#ip nat outside

به این صورت سرور1 از طریق آدرس 192.168.12.12 با سرور2 می تواند ارتباط برقرار کند و سرور2 از طریق آدرس 192.168.12.11 با سرور1 می تواند ارتباط برقرار کند.

DHCP چیست؟ و چگونه در تجهیزات سیسکو استفاده می شود !

هر دستگاه یا هر اینترفیسی که از TCP/IP استفاده می کند. برای استفاده از شبکه و ارتباطات خود نیاز به یک آدرس منطقی یا همان IP دارد. که این IP را می توان به دو صورت زیر به دستگاه اختصاص داد:

  1. Static
  2. Dynamic
Image

 

Static :


در این حالت اختصاص IP به صورت دستی انجام می گیرد یعنی روی هر دستگاه کاربر خودش یک IP مشخص کند. اختصاص IP به صورت Static مزایای و معایب خاص خودش را دارد که به برخی از آنها اشاره می کنیم:
مزایا :

  • هر دستگاه دقیقا مشخص است که از چه IP استفاده می کند.
  • به لحاظ امنیتی استفاده از روش Static بهتر است چون در این روش کلاینت ها را بهتر می توان کنترل کرد.
  • نیاز به راه اندازی و استفاده از سرویس خاصی ندارد.
  • نگه داری و عیب یابی ساده تر انجام می شود.

معایب :

  • برای آینده نگری و عدم بروز مشکل باید برای سیستم آدرس دهی ، یک برنامه دقیق و مشخص داشته باشیم.
  • در صورتی که تعداد دستگاه زیاد باشند نیاز به وارد کردن IP به صورت دستی روی تک تک دستگاه است که کار مشکلی است.
  • احتمال استفاده شدن یک IP برای دو دستگاه وجود دارد که نتیجه آن IP Conflict و مختل شدن عملکرد دستگاه ها است.
  • در صورت نیاز به تغییر در سیستم آدرس دهی این تغییرات باید روی تک تک دستگاه ها انجام شود.

نکته : معمولا دستگاه هایی که در شبکه یک سرویس خاص را ارائه می دهند از IP Static استفاده می کنند. چون کلاینت ها از این سرویس استفاده می کنند درنتیجه نباید IP این دستگاه ها تغییر کند. روترها ، سرور ها از این دسته می باشند.

Dynamic :


در این حالت اختصاص IP به صورت خودکار و توسط سرویس (Dynamic Host configuration Protocol (DHCP انجام می گیرد. این پروتکل وظیفه مدیریت سیستم آدرسی دهی شبکه را برعهده می گیرد. DHCP این اجازه را به دستگاه های شبکه می دهد که درخواست برای دریافت IP داشته باشند. DHCP را می توان روی تجهیزات مختلف مانند روتر ، سوئیچ ، ویندوز سرور ، مودم و … راه اندازی کرد و به آن DHCP Server گفته می شود و کلاینتی که درخواست IP می کند را DHCP client می نامند.

نحوی عملکرد DHCP :


برای DHCP Server یک رنج IP مشخص می شود که از این رنج IP برای اختصاص به کلاینت ها استفاده می کند. DHCP Server علاوه بر مشخص کردن IP برای کلاینت می تواند IP Gateway ، DNS و … را به کلاینت اعلام کند. برای دریافت IP بین DHCP Client و DHCP Server چهار بسته در و بدل می شود.
زمانی که یک کلاینت به شبکه متصل می شود از رنج IP شبکه و DHCP Server بی خبر است یک بسته به عنوان DHCP Discover به آدرس MAC مقصد ffff.ffff.ffff و IP مبدا 0.0.0.0 و IP مقصد 255.255.255.255 به صورت Broadcast روی شبکه ارسال می کند. DHCP Server با دریافت این بسته به عنوان پاسخ یک بسته به عنوان offer ارسال می کند که حاوی اطلاعات مانند IP ، Default Gateway و … می باشد. DHCP Client با دریافت بسته offer و بررسی اطلاعات آن ، به عنوان تایید یک بسته Request ارسال می کند. DHCP Server با دریافت بسته Request به عنوان تایید این مراحل و اختصاص IP یک بسته Acknowledgement ارسال می کند و به این ترتیب مراحل اختصاص IP پایان می پذیرد.

Image

 

معایب و مزایای استفاده از DHCP :


مزایا :

  • آدرسی دهی به صورت خودکار و سریع انجام می شود.
  • برای مکان هایی که کاربران آن افراد ثابتی نیستند بسیار مناسب است.
  • مدیریت سیستم آدرسی دهی و رنج IP آدرس مورد استفاده توسط سرویس DHCP به صورت خودکار انجام می شود.
  • احتمال IP Conflict و مختل شدن عملکرد دستگاه ها بسیار کم است.
  • در صورت نیاز به تغییر در سیستم آدرس دهی این تغییرات به سادگی انجام می شود.

معایب :

  • نیاز به نگه داری دارد.
  • دستگاه ها ، IP مشخصی ندارند در نتیجه کنترل آنها مشکل است.
  • امکان حمله DHCP Spoofing برای این سرویس وجود دارد.
  • برای راه اندازی نیاز به یک DHCP Server داریم در صورتیکه تجهیزات موجود در شبکه این را قابلیت نداشته باشند باید یک دستگاه به این منظور تهیه شود.
  • برای همه تجهیزات مثل سرورها نمی توان از DHCP استفاده کرد.

 

فعال کردن DHCP در تجهیزات سیسکو :


از تجهیزات سیسکو مانند روتر و سوئیچ می توان به عنوان DHCP Server استفاده کرد. برای اینکار از دستورات زیر استفاده می کنیم:
در ابتدا یک Pool ایجاد می کنیم:

R1(config)# ip dhcp pool itpro

حالا باید رنج شبکه ای که می خواهیم از آن به کلاینت IP اختصاص دهیم را مشخص کنیم :

R1(dhcp-config)# network 192.168.1.0 255.255.255.0

سپس پارامترهای دیگر مثل Default Gateway ، DNS ، Domain و … را مشخص می کنیم:

R1(dhcp-config)# default-router 192.168.1.1
R1(dhcp-config)# dns-server 192.168.1.5 195.170.0.1
R1(dhcp-config)# domain-name itpro.ir

مدت زمان نگه داری IP را براساس روز مشخص می کنیم:

R1(dhcp-config)# lease 9

اگر بخواهیم بخشی از رنج IP را برای موارد خاص مثل سرورها رزرو کنیم از دستور زیر استفاده می کنیم:

R1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.5
R1(config)# ip dhcp excluded-address 192.168.1.10

 

DHCP Relay Agent :


همانطور که دیدید بسته DHCP به صورت Broadcast ارسال می شوند حالا شبکه ای را در نظر بگیرد که DHCP Server ان در شبکه ای local نیست و در یک شبکه دیگر قرار دارد. که باعث می شود درخواست های کلاینت ها به دست DHCP Server نرسد(در بین شبکه ها روتر قرار دارد و یکی از وظایف روتر جلوگیری از ارسال بسته های Broadcast از یک شبکه به شبکه دیگر است). DHCP Relay Agent این مشکل را برای ما حل می کند. دستگاهی که به عنوان DHCP Relay Agent عمل می کند بسته های درخواستی کلاینت که به صورت Broadcast است را به سمت DHCP Server به صورت unicast ارسال می کند. در واقع DHCP Relay Agent به عنوان یک واسطه بین کلاینت و سرور کار می کند.

Image

برای فعال کردن این قابلیت روی روتر باید دستور زیر را روی اینترفیسی که به شبکه متصل به کلاینت است وارد کنیم:

R1(config)#interface FastEthernet0/0
R1(config-if)#ip helper-address 192.168.1.1