InterVLAN Routing – برقراری ارتباط بین VLANها با استفاده از روتر – Router on Stick

در خدمت دوستان هستیم در ادامه مباحث سیسکو امروز می خوایم در رابطه InterVLAN Routing صبحت کنیم امیدارم که براتون مفید واقع بشود پس همراه ما باشید.
همانطور که قبلا گفته شد VLAN ها شبکه را به Broadcast Domainهای کوچکتر تقسیم می کنند و همچنین باعث می شوند که بین این شبکه ها ارتباطی وجود نداشته باشد. برای برقراری ارتباط بین این گروه از شبکه ها بودن عبور ترافیک Broadcast از InterVLAN Routing استفاده می شود.

InterVLAN Routing با استفاده از یک روتر خارجی:


یک سوئیچ لایه دو می تواند با اتصال به یک روتر ارتباط بین VLANها را برقرار کند و این برقراری ارتباط می تواند توسط لینک های جداگانه برای هر VLAN انجام شود و یا با استفاده از یک لینک Trunk از سوئیچ به روتر انجام پذیرد.

با توجه به تعداد محدود پورت رو روتر معمولا از یک لینک ترانک برای برقراری ارتباط بین VLANهای استفاده می شود و به ان Router on Stick گفته می شود.

  • نکته : با تمام سوئیچ هایی که از VLAN پشتیبانی می کنند می توان این ویژگی را پیاده سازی کرد.
  • نکته : کل ترافیک بین VLAN ها روی یک لینک منتقل می شود و در صورت قطع شدن یا وجود ترافیک زیاد (بیشتر از ظرفیت لینک) ، باعث ایجاد مشکل در ارتباط بین VLAN ها خواهد شد.
  • نکته : این ویژگی در دنیای واقعی کاربرد بسیار زیادی دارد چون روی روترها تعداد پورت ها کم هستند و در صورت نیاز به پورت بیشتر نیاز به خرید ماژول می باشد که این کار مقرون به صرفه نیست در نتیجه با استفاده از این ویژگی این کمبود پورت جبران می شود.

 

یک مثال :


یک شبکه را فرض کنید که دارای دو VLAN 10 و VLAN 20 است که پورت Fastethernet 0/1 به VLAN 10 و Fastethernet 0/2 به VLAN 20 و Fastethernet0/3 به پورت Fastethernet 0/0 روتر متصل است حالا می خواهیم ارتباط بین VLAN 10 و VLAN 20 را با استفاده از روتر برقرار کنیم:

Image

در ابتدا باید روی سوئیچ ، پورت Fastethernet 0/1 را عضو VLAN 10 کنیم با استفاده از دستور زیر اینکار را انجام می دهیم:

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
Switch(config-if)#

  • نکته : در صورتی که vlan از قبل ایجاد شده نباشد وارد کردن دستور switchport access vlan 10 باعث ایجاد VLAN 10 می شود.

برای Fastethernet 0/2 نیز این دستورات را انجام می دهیم:

Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
Switch(config-if)#

حالا باید پورت Fastethernet0/3 را در وضعیت Trunk قرار دهیم تا توانایی حمل ترافیک مربوط به VLAN ها را داشته باشد که برای اینکار به صورت زیر عمل می کنیم:

Switch(config)#interface fastethernet 0/3
Switch(config-if)#switchport trunk encapsulation dot1q 
Switch(config-if)#switchport mode trunk 
Switch(config-if)#

تنظیمات سمت سوئیچ ما کامل شده حالا باید روتر را تنظیم کنیم:
در ابتدا Fastethernet 0/0 را به صورت زیر تنظیم می کنیم:

Router(config)#interface fastethernet 0/0
Router(config-if)#no shut

حالا باید Subinterfaceها را بسازیم به صورت زیر:

Router(config)#interface fastEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.2 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.2 255.255.255.0
Router(config-subif)#exit

تمام تنظیمات ما انجام شده و حالا دو VLAN با یکدیگر ارتباط دارند.

امیدوارم که این آموزش مفید واقع شده باشد.
پیروز ، موفق و ITPro باشید

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *